The Middle Earth Project Forum Index
 
 
 
The Middle Earth Project Forum IndexFAQSearchRegisterLog in

Patch 2.0 compatibility
Goto page: 1, 2, 3, 4  >
 
Post new topic   Reply to topic    The Middle Earth Project Forum Index -> The Team Forum -> Archive
Previous topic :: Next topic  
Author Message
Chris93
Team

Offline

Joined: 05 Apr 2013
Posts: 1,965
Localisation: Italia

PostPosted: Mon 18 Nov - 16:28 (2013)    Post subject: Patch 2.0 compatibility Reply with quote

Guys, patch 2.0 is out.
I'm gonna check "common" folder to find out differences between the new and the old files. What about you? Splitting the work in tasks will be easier for everyone  Okay
Back to top
Publicité






PostPosted: Mon 18 Nov - 16:28 (2013)    Post subject: Publicité

PublicitéSupprimer les publicités ?
Back to top
Lonhaldar
Administrateur

Offline

Joined: 06 Mar 2013
Posts: 3,190
Localisation: France

PostPosted: Mon 18 Nov - 16:41 (2013)    Post subject: Patch 2.0 compatibility Reply with quote

Ok! I'll check the decisions files!
I just looked at the new "religious_titles" file, and it seems that we can work with the cardinal mechanic :
Quote:
title_cardinal = {
religion = catholic
can_elect_head = yes

grant_limit = 9

realm_in_name = no
show_as_title = yes

opinion_effect = 20
dignity = 0.9

monthly_salary = 0.1
monthly_prestige = 0.5

allow = {
religion = catholic
is_theocracy = yes

NOT = {
top_liege = {
any_vassal = {
any_claim = {
title = k_papal_state
}
}
}
}
}

gain_effect = {
}

lose_effect = {
}


message = yes
} 

Back to top
Chris93
Team

Offline

Joined: 05 Apr 2013
Posts: 1,965
Localisation: Italia

PostPosted: Mon 18 Nov - 16:50 (2013)    Post subject: Patch 2.0 compatibility Reply with quote

Very good.
Back to top
Lonhaldar
Administrateur

Offline

Joined: 06 Mar 2013
Posts: 3,190
Localisation: France

PostPosted: Mon 18 Nov - 17:12 (2013)    Post subject: Patch 2.0 compatibility Reply with quote

Decisions are updated!
You wants some help with the common files, there's quite a lot?  Wink
Back to top
Chris93
Team

Offline

Joined: 05 Apr 2013
Posts: 1,965
Localisation: Italia

PostPosted: Mon 18 Nov - 17:18 (2013)    Post subject: Patch 2.0 compatibility Reply with quote

Ok Lon. You could check whether anything is changed in these folders:
graphicalculturetypes
nicknames
objectives


Okay
Back to top
Lonhaldar
Administrateur

Offline

Joined: 06 Mar 2013
Posts: 3,190
Localisation: France

PostPosted: Mon 18 Nov - 17:21 (2013)    Post subject: Patch 2.0 compatibility Reply with quote

ok i do it now Wink
Back to top
Chris93
Team

Offline

Joined: 05 Apr 2013
Posts: 1,965
Localisation: Italia

PostPosted: Mon 18 Nov - 18:11 (2013)    Post subject: Patch 2.0 compatibility Reply with quote

Ok, i've just merged the differences between the folders/files. I've noticed we have some missed files in our common folder (in bold what seems to be useful):
Folders:
on_actions
religion_modifiers (but it seems to be useless for our mod)
religious_titles (Has been added now with the new patch)
stories (useless)
Files:
achievements (Has been added now)
combat_tactics 
disease (useless for now)
triggered_modifiers
Back to top
Chris93
Team

Offline

Joined: 05 Apr 2013
Posts: 1,965
Localisation: Italia

PostPosted: Fri 22 Nov - 13:54 (2013)    Post subject: Patch 2.0 compatibility Reply with quote

Patch 2.0.1 ha been released today


2013-11-22: v2.0.1
--------------------

- Added missing Jewish religious icons
- No longer possible to play as a Jew without the Sons of Abraham DLC
- The "Legitimize Bastard" decision now sets the correct dynasty
- Cathars now have access to the "Absolute Cognatic" succession law
- Jewish priests are now allowed to marry
- The kingdom of Jerusalem decisions to vassalize the Knights Templar and Hospitaller now work
- Heresies are now also shown on the religion page in the ledger
- The Knights of Santiago now have their historical activation date and first Grandmaster
- Fixed a bug where an antipope installed as proper Pope in Rome would get an antipope successor
- Fixed a bug where the Pope could restore himself in Rome infinitely, for astronomical amounts of Piety
- GamersGate users no longer incorrectly get the Steam overlay
- Different platforms don't get different checksums anymore
- You can no longer get a barony level character when pressing the Random Character button
- Added more descriptive text when Ironman is disabled
- Removed some ways in which one could cheat in Ironman
- Disabled autosave to cloud storage option in settings if no cloud storage is available
- Fixed some bugs with the new 'hold_election' effect
- AI: Massively reduced the chance that it will create antipopes, for now
- Fixed an issue with ridiculously powerful Mongol stacks if there were Jews in the world
- Fixed so Shift + I does not act like Shift + Insert anymore
- Religion status changes (Mending the Schism, etc) are now properly reset on resign
- Fixed a bug where most councillor job action events were men only
- Blocked Ultimogeniture for West African pagans
- Limited the intrigue gained from certain successful plots
- Fixed error in 'Viking Raider' achievement script
- Fixed a bug with Zoroastrian Xwedodah marriages not being considered sacred
- No longer possible to select Jews in multiplayer if the host does not have Sons of Abraham
Back to top
Blood Royal
Team

Offline

Joined: 18 Jul 2013
Posts: 1,077
Localisation: Denmark

PostPosted: Fri 22 Nov - 14:01 (2013)    Post subject: Patch 2.0 compatibility Reply with quote

Ahh, I hadn't seen this thread at all!

I'll take the "events" folder then and post the fixed vanilla files here Okay
Back to top
Chris93
Team

Offline

Joined: 05 Apr 2013
Posts: 1,965
Localisation: Italia

PostPosted: Fri 22 Nov - 14:08 (2013)    Post subject: Patch 2.0 compatibility Reply with quote

Okay
Back to top
Blood Royal
Team

Offline

Joined: 18 Jul 2013
Posts: 1,077
Localisation: Denmark

PostPosted: Fri 22 Nov - 14:33 (2013)    Post subject: Patch 2.0 compatibility Reply with quote

Updated events folder to latest versions, also added:

ward_events
personality_traits_events
guardian_events
battle_events
(I skimmed through them and they are quite neutral - though maybe not appropriate for culture_group_melkor since wards/guardians events are probably done differently in orcish cultures, but until we make custom events for them I think it's better than nothing)

Fixed folder is here (I'll also include it in my next general update, just in case). It should be safe to copy/paste everything over directly.

http://www.sendspace.com/file/6fqe4o
Back to top
Chris93
Team

Offline

Joined: 05 Apr 2013
Posts: 1,965
Localisation: Italia

PostPosted: Fri 22 Nov - 14:38 (2013)    Post subject: Patch 2.0 compatibility Reply with quote

Thanks!
PS: Little suggestion for you, and for us too! Open a topic and put there all your last updates and mini updates, everything would be clearer and neater  Okay
Back to top
Blood Royal
Team

Offline

Joined: 18 Jul 2013
Posts: 1,077
Localisation: Denmark

PostPosted: Fri 22 Nov - 14:44 (2013)    Post subject: Patch 2.0 compatibility Reply with quote

I put all my updates on the current alpha thread, when available -These, and everything else I've included in mini updates on various threads get posted in one package with a changelog included when I make a general update to the alpha tread Okay So as long as everything i've posted on the alpha thread gets into the current build, nothing should be lost.
Back to top
Chris93
Team

Offline

Joined: 05 Apr 2013
Posts: 1,965
Localisation: Italia

PostPosted: Fri 22 Nov - 14:52 (2013)    Post subject: Patch 2.0 compatibility Reply with quote

Okay
Back to top
Blood Royal
Team

Offline

Joined: 18 Jul 2013
Posts: 1,077
Localisation: Denmark

PostPosted: Fri 22 Nov - 15:00 (2013)    Post subject: Patch 2.0 compatibility Reply with quote

I'll take a look at the /interface folder now, and also try and change some things to adapt it to our mod (I see the coat_of_arms.txt for example uses vanilla religion groups - I'll try and replace stuff like that too, as it might be causing crashes).
Back to top
Contenu Sponsorisé






PostPosted: Today at 09:38 (2017)    Post subject: Patch 2.0 compatibility

Back to top
Display posts from previous:   
Post new topic   Reply to topic    The Middle Earth Project Forum Index -> The Team Forum -> Archive All times are GMT + 1 Hour
Goto page: 1, 2, 3, 4  >
Page 1 of 4

 
Jump to:  

Index | Administration Panel | Forum hosting | Free support forum | Free forums directory | Report a violation | Conditions générales d'utilisation
Template lost-kingdom_Tolede created by larme d'ange
Powered by phpBB © 2001, 2005 phpBB Group